Внимание

Форум находится в режиме только для чтения.

Не отображаются баннера

  • Ответов 8
  • Спасибо получено: 1

Андрей создал эту тему: Не отображаются баннера

Добрый день. Возникла такая проблема с шаблоном OT Corporatetree Template:

Warning: require_once(N:\home\test1.ru\www\modules\mod_ot_scrollerDShelper.php) [function.require-once]: failed to open stream: No such file or directory in N:\home\test1.ru\www\modules\mod_ot_scroller\mod_ot_scroller.php on line 12

Fatal error: require_once() [function.require]: Failed opening required 'N:\home\test1.ru\www\modules\mod_ot_scrollerDShelper.php' (include_path='.;C:\php\pear') in N:\home\test1.ru\www\modules\mod_ot_scroller\mod_ot_scroller.php on line 12

пути изображения менял, но это ничего не дало. Подскажите что не так. Заранее благодарен.
#1
  • Ответов 150
  • Репутация: 3
  • Спасибо получено: 4

Dima ответил в теме Не отображаются баннера

После каких действий у Вас возникла эта ошибка?
#2
  • Ответов 8
  • Спасибо получено: 1

Андрей ответил в теме Не отображаются баннера

На всех этапах работы с этим модулем баннера не отображались вообще(при создании Категории, Баннеров) затем начал подгонять модуль под параметры Квикстарта, установил галочку отображать только на главной и после этого появилась вышеупомянутая ошибка
#3
  • Ответов 8
  • Спасибо получено: 1

Андрей ответил в теме Не отображаются баннера

А теперь еще взял удалил модуль ОТ Scroller, заново устанавливаю пишет Установка прошла успешно, но в расширениях Модули его нет.
#4
  • Ответов 150
  • Репутация: 3
  • Спасибо получено: 4

Dima ответил в теме Не отображаются баннера

Попробуйте полностью удалить модуль, можно даже вручную в папках. Почистить кэш, и заново установить.
#5
  • Ответов 8
  • Спасибо получено: 1

Андрей ответил в теме Не отображаются баннера

Удалил модуль(и в папках, скачал заново в "55 шаблонах"), заново установил ничего нового. Проблема как я понял в пути к изображению. Решил пойти от обратного посмотрел как сделано в Квикстарте, в модуле слайд баннера OT Scroller посмотрел путь к папке (images/demo/banner-slider), но в меню Компоненты в разделе Баннера путь к изображениям совершенно другой (images/banners/white.png) и соответственно другие картинки. Где эти Компоненты-Баннера которые выводят изображения на сайт?
#6
  • Ответов 150
  • Репутация: 3
  • Спасибо получено: 4

Dima ответил в теме Не отображаются баннера

По идее строки в ошибке, которая у вас выскакивала, должны отвечать за пути вывода изображений.
И еще уточните, у Вас все работает нормально кроме этого модуля?
#7
  • Ответов 8
  • Спасибо получено: 1

Андрей ответил в теме Не отображаются баннера

На данном этапе все работает блоки, меню, лого
#8
  • Ответов 150
  • Репутация: 3
  • Спасибо получено: 4

Dima ответил в теме Не отображаются баннера

Вы можете посмотреть что прописано в 12 строке по пути ошибки, и найти такой же файл в quick start и посмотреть что там прописано, возможно это поможет в решении проблемы. И еще вопрос(врятли это связано, но тем не менее), Вы работаете denwer или open server?
#9
  • Ответов 8
  • Спасибо получено: 1

Андрей ответил в теме Не отображаются баннера

Вообщем вопрос с модулем слайдеров решен. Может кому пригодится
строку
require_once (dirname(__FILE__).DS.'helper.php');
заменил на
if (!defined('DS')){
define('DS',DIRECTORY_SEPARATOR);
}

require_once (dirname(__FILE__). '/helper.php');
#10
Спасибо сказали: Dima
Время создания страницы: 0.169 секунд

© Школа Федора Васильева, 2014-2018. Все права защищены.

Видео уроков:
Отзывов:
Активных подписчиков:
Клиентов:

 


Почта: Этот адрес электронной почты защищён от спам-ботов. У вас должен быть включен JavaScript для просмотра.

Тел: +7 960-375-50-04

По каким расширениям для Joomla вы хотите получить видеокурс?

Голосовать Я уже голосовал!

Мы переехали на новый адрес fedorvasilev.com